Gantt free con Microsoft Excel

gantt-excel Quando si deve gestire dei progetti è importante realizzare un gantt delle attività. Lo strumento più utilizzato e comunemente presente nei PC aziendali è MS Project. Esistono diversi altri software e piattaforme disponibili per la gestione dei progetti (“i migliori software di project management”), tuttavia senza dover ricorrere a piattaforme complicate è possibile sviluppare un semplice Gantt con Excel.


In questo articolo spiegheremo come realizzare un Gantt con Microsoft Excel senza dover usare codice visual basic.

Continua seguirci! Nei prossimi articoli spiegheremo come creare un Gantt con Excel utilizzando del codice visula basic che ti permetterà di avere uno strumento molto più completo.

Utilizzeremo per questo lavoro la versione 2007 di Microsoft Excel, ma le istruzioni sono chiaramente applicabili alle versioni precedenti e successive.

Apriamo un nuovo file Excel e salviamolo con il nome “gantt-con-excel.xls” nella versione 97/2003 di modo che sia utilizzabile anche sulle versioni precedenti del software. Rinominiamo il foglio1 in “gantt” ed il foglio2 in “ferie”; cancelliamo il foglio3.

Sezione giorni lavorativi e ferie:

per poter gestire al meglio il progetto, considerando che alcuni giorni dell’anno sono festivi è innanzi tutto necessario definire un calendario ferie. Ad esempio nel 2015 mettiamo come ferie i giorni 01-gen., 02-gen., 05-gen., 06-gen, 06-apr., 01-mag., dal 10 al 22 agosto (chiaramente ogni uno è libero di mettere le date che vuole)

gantt con excel

Sezione attività:

posizioniamoci sulla seconda riga ed inseriamo le seguenti intestazioni:

  • Attività (colonna A)
  • Start (colonna B). Per la data inizio dell’attività è possibile inserire puntualmente la data inizio
  • End (colonna C). È necessario inserire manualmente la data fine
  • Durata (colonna E). È calcolata automaticamente inserendo la formula =GIORNI.LAVORATIVI.TOT(B4;C4;ferie!$A$2:$A$502)

Sezione risorse:

(colonne E – K) per avere un minimo di gestione risorse possiamo definire che le colonne dalla E alla K conterranno le risorse da assegnare al progetto. La cosa migliore è quella di assegnare ad ogni colonna una sola risorsa (nel nostro esempio le chiameremo Ris1 … 7)

Sezione temporale di progetto:

(colonne L – IV) Possiamo riempire l’asse temporale partendo ad esempio dal primo lunedì dell’anno;

  • per esempio inseriamo 05/01/12 nella cella L2
  • sulla cella successiva inseriamo la seguente formula “=L2+1” e trasciniamo la formula fino alla cella “P” compresa;
  • posizioniamoci sulla cella “Q” ed inseriamo la formula “=L2+7”, quindi inseriamo la formula “=Q2+1” sulla cella R e trasciniamo fino alla cella U;
  • uniamo le celle L1-P1 ed inseriamo la seguente formula “=NUM.SETTIMANA(L2)”;
  • copiamo questa cella unita ed incolliamola sulla cella Q1;

A questo punto copiamo le celle Q1-U2 ed incolliamole sulla cella V1, quindi sulla cella AA1, AF1 e così via fino alla cella IV1. Se salviamo il file in formato .xlsx abbiamo a disposizioni maggiori colonne e quindi possiamo creare un Gantt più lungo.

Una nota sulla formula NUM.SETTIMANA: questa formula restituisce il numero della settimana ricevendo in input una data, tuttavia non sempre il calcolo risulta corretto.  Questo è dovuto all’anno in esame, ed è sufficiente aggiungere alla formula il valore +1 o -1. Il calcolo della settimana dell’anno è regolamentato dalla normativa UNI 8601 che stabilisce che la settimana 01 dell’anno è definita come (sono tutte equivalenti):

  • la settimana che contiene il primo giovedì dell’anno,
  • la settimana che contiene il 4 gennaio,
  • la prima settimana che contiene quattro, o più, giorni del nuovo anno,
  • la settimana che inizia con il lunedì fra il 29 dicembre ed il 4 gennaio,
  • se il 1º gennaio è un lunedì, martedì, mercoledì o giovedì allora è nella settimana 01. Se capita di venerdì, sabato o domenica allora è nell’ultima settimana (la 52 o 53) dell’anno passato.

Il numero della settimana può essere calcolato contando i giovedì: la settimana 10 contiene il decimo giovedì dell’anno.

Applicando una delle regole sopra esposte è possibile facilmente calcolare il numero della settimana di qualsiasi giorno di qualsiasi anno. Nell’articolo “calcolo del numero della settimana” trovare un semplice codice per VBA e PHP per calcolare il giorno della settimana.

Sezione grafica

posizioniamoci sulla cella L3 ed inseriamo la seguente formula “=SE(E(L$2>=$B3;L$2<=$C3);”x”;””)”, quindi trasciniamola fino alla cella IV3. Selezioniamo l’intervallo “L3:IV3” e trasciniamolo fino alla riga 500.

gantt con escel

A questo punto non resta che rendere graficamente migliore il nostro Gannt, quindi selezioniamo l’intervallo “L3:IV500” ed impostiamo il colore del carattere a blu. Selezioniamo la formattazione condizionale (dal menu Home se usiamo Excel 2007 o successivo) ed impostiamola di modo che se le celle sono uguali ad “x” allora il colore del motivo è blu (lo stesso usato precedentemente per il carattere)

gantt con excel

Dato che le risorse occupano spazio e che per il momento non ci facciamo ancora molto (leggi il prossimo tutorial per lo sviluppo di questa parte!) selezioniamo le colonne E:K quindi dal menu “raggruppa e struttura” selezioniamo raggruppa. Ora se vogliamo possiamo nasconderle facilmente.

gantt con excel

Possiamo ancora migliorare il nostro foglio gantt dato che ci potrebbe essere utile avere evidenziate le date che corrispondono alle ferie. Inseriamo una riga tra la prima e la seconda, posizioniamoci sulla cella L2 quindi inseriamo la seguente formula: “=SE(VAL.NON.DISP(CERCA.VERT(L3;ferie!$A:$A;1;FALSO));””;CERCA.VERT(L3;ferie!$A:$A;1;FALSO))”, quindi trasciniamola fino alla cella IV2.

Ora posizioniamoci sulla cella L3 ed inseriamo la formattazione condizionale =L$2 allora colore di sfondo grigio. Copiamo il formato sulle celle successive e nascondiamo la riga 2.

gantt con excel

Ora potete rendere migliore l’aspetto del nostro file aggiungendo filtri o modificando le formattazioni dei vari campi.

Il nostro primo Gantt con Excel è stato realizzato! Leggi il prossimo tutorial sul Gantt in Excel, troverai strumenti più sofisticati ed un po’ di codice Visual Basic for Application (VBA)

Il file è scaricabile al seguente link: gantt-con-excel.xls.


Puoi anche approfondire l’argomento leggendo i nostri percorsi di crescita personale e professionale.

 

5 thoughts on “Gantt free con Microsoft Excel

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *